Cisco 841MのタグVLANにおけるLAN内スループット

Cisco C841M-4X-JSEC/K9はブロードバンドルーターとしては性能的にダメダメですが、スイッチ部分の性能はどの程度あるのかスループットを計測してみました。

計測環境

VLAN2を追加するためここの設定に加え以下のconfigを投入します。

ip dhcp pool dhcp-lan2
 network 192.168.101.0 255.255.255.0
 default-router 192.168.101.1 
 dns-server 192.168.101.1
!
interface GigabitEthernet0/2
 switchport access vlan 2
!
interface GigabitEthernet0/3
 switchport access vlan 2
!
interface Vlan2
 ip address 192.168.101.1 255.255.255.0
 ip nat inside

YAMAHA RTX1210やNEC UNIVERGE IX2105でタグVLANを設定すると、スイッチポートの各ポートはタグ付きポートの構成(trunk)になりますが、Ciscoはaccess/trunkのどちらも選択することが出来、このあたりはさすがCiscoといったところです。

iperf3を(1)同一VLAN内となるA-BとC-Dで同時、(2)VLAN間となるA-D、(3)VLAN間となるA-DとC-Bで同時に実行しスループットの測定を行います。C841Mのファームウェアは15.5(3)M9となります。

計測結果

Mbps CPU 消費電力
無負荷時 8% 8.4W
(1) VLAN内で同時 A-B 942
C-D 942
8% 8.4W
(2) VLAN間 A-D 623 99% 9.1W
(3) VLAN間で同時 A-D 300
C-B 309
98% 9.1W

VLAN内であればハードウェア処理でWire speedが出ますが、VLAN間だとCPU処理となりルーターにかなり負荷がかかります。Catalyst 2960LとかだとVLAN間ルーティングがハードウェア処理されているので、ちょっと期待しましたが「餅は餅屋」ということですね。RTX1210やIX2105と同様、VLAN間の通信が多い場合にはVLAN間ルーティングがハードウェア処理できるスイッチを使うべきでしょう。

ちなみに、上記計測はaccess portでのテストでしたが、trunk設定にしてもスループット上のデメリットはなさそうです。

interface GigabitEthernet0/0
!
interface GigabitEthernet0/1
 switchport trunk native vlan 2
 switchport trunk allowed vlan 1,2,1002-1005
 switchport mode trunk
!
interface GigabitEthernet0/2
 switchport access vlan 2
!
interface GigabitEthernet0/3
 switchport trunk allowed vlan 1,2,1002-1005
 switchport mode trunk

のように変更して、

CentOS7 A・・・Gi0/0(vlan1のaccess port)に直接接続
CentOS7 B・・・Gi0/1(trunk native vlan2)にVLANタグ1を外して接続
CentOS7 C・・・Gi0/2(vlan2のaccess port)に直接接続
CentOS7 D・・・Gi0/3(trunk native vlan1)にVLANタグ2を外して接続

し、(1)と同様のテストを実施しましたが、A-B,C-Dそれぞれ939Mbpsが出ました。ポート数が少ないですが、Ciscoのスイッチと同様に扱えるのはC841Mのメリットです。

C841MのConfig

検証に使った全体のconfigは以下となります。

ip dhcp pool dhcp-lan1
 network 192.168.100.0 255.255.255.0
 default-router 192.168.100.1 
 dns-server 192.168.100.1 
!
ip dhcp pool dhcp-lan2
 network 192.168.101.0 255.255.255.0
 default-router 192.168.101.1 
 dns-server 192.168.101.1 
!
ip cef
no ipv6 cef
!
interface GigabitEthernet0/2
 switchport access vlan 2
!
interface GigabitEthernet0/3
 switchport access vlan 2
!
interface GigabitEthernet0/4
 ip address dhcp
 ip nat outside
!
interface Vlan1
 ip address 192.168.100.1 255.255.255.0
 ip nat inside
!
interface Vlan2
 ip address 192.168.101.1 255.255.255.0
 ip nat inside
!
ip dns server
ip nat inside source list 1 interface GigabitEthernet0/4 overload
!
access-list 1 permit 192.168.100.0 0.0.1.255

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です