Cisco 841MのPPPoEスループット

Cisco C841M-4X-JSEC/K9のPPPoEのスループットを測定してみました。NAT+FirewallだけでもほぼCPUを使い切ってスループットが出ないC841Mですが、さらにPPPoE接続にするとどの程度影響があるのでしょうか。

計測環境

CentOS7 Aをクライアント、CentOS7 Bをサーバーにし、iperf3を実行しスループットの測定を行います。テストに使うPPPoEサーバーはMikrotik社のソフトウェアアプライアンス CHR(Cloud Hosted Router)のv6.44.3を使いました。フレッツ環境を意識し、PPPoEサーバーのMTUは1454に設定しています。C841Mのファームウェアは15.5(3)M9となります。

計測結果

CentOS7 Aでのiperf3の実行結果が以下となります。-Mオプションを使ってMSSを変えてテストを行っています。消費電力はTAP-TST10での目測値で無負荷時は6.4Wとなります。後で掲載のconfigにあるように最低限のフィルタを設定しております。

receiver sender
MSS Mbps CPU 消費電力 Mbps CPU 消費電力
1414(指定なし) 179 99% 7.2W 192 99% 7.2W
1200 152 99% 7.2W 164 99% 7.2W
800 102 99% 7.2W 109 99% 7.2W
400 50.3 99% 7.2W 53.9 99% 7.2W

receiverの結果はCentOS7 Aから見てダウンロード方向、senderの結果はCentOS7 Aから見てアップロード方向の計測結果となります。日本の家庭では標準的な接続環境であるPPPoEだと使い物にならない性能です・・・。

C841MのConfig

テストに使ったconfigは以下の通りです。

ip dhcp pool dhcp-lan1
 network 192.168.100.0 255.255.255.0
 default-router 192.168.100.1 
 dns-server 192.168.100.1 
!
ip cef
no ipv6 cef
!
interface GigabitEthernet0/4
 no ip address
 pppoe enable group global
 pppoe-client dial-pool-number 1
!
interface Vlan1
 ip address 192.168.100.1 255.255.255.0
 ip nat inside
!
interface Dialer1
 mtu 1454
 ip address negotiated
 ip access-group wan-to-lan in
 ip access-group lan-to-wan out
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1414
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname ppp1
 ppp chap password 0 test
 ppp ipcp dns request accept
 ppp ipcp route default
!
ip dns server
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip access-list extended lan-to-wan
 permit ip any any reflect mirror timeout 300
ip access-list extended wan-to-lan
 permit icmp any any
 permit udp any eq domain any
 evaluate mirror 
!
access-list 1 permit 192.168.100.0 0.0.0.255

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です