Cisco 841MのNATスループット(Firewallなしのケース)

Cisco C841M-4X-JSEC/K9のNAT(PAT)のスループットをFirewall(フィルタ)なしのケースで測定してみました。NATを入れると遅いという噂のあるC841Mですが、どの程度のスループットが出るのでしょうか。

計測環境

スイッチポート0(gigabitEthernet0/0)にCentOS7 Aをクライアント、gigabitEthernet0/4配下にCentOS7 Bをサーバーとして配置し、iperf3を実行しスループットの測定を行います。C841Mのファームウェアは15.5(3)M9となります。

計測結果

CentOS7 Aでのiperf3の実行結果が以下となります。-Mオプションを使ってMSSを変えてテストを行っています。消費電力はTAP-TST10での目測値で無負荷時は6.3Wとなります。後で掲載のconfigにあるようにフィルタ等は一切設定しておりません。

receiver sender
MSS Mbps CPU 消費電力 Mbps CPU 消費電力
1460(指定なし) 448 98% 7.0W 462 98% 7.0W
1200 366 98% 7.1W 378 98% 7.0W
800 242 98% 7.0W 248 98% 7.0W
400 119 98% 7.0W 122 98% 7.0W

receiverの結果はCentOS7 Aから見てダウンロード方向(iperf3で-Rオプション)、senderの結果はCentOS7 Aから見てアップロード方向(iperf3で-Rオプションなし)の計測結果となります。単純routingの結果と比較すると、NATを入れるだけで悲しくなるくらいスループットが低下してしまいますね。CPU負荷が高いことからもわかるようにNATについてはハードウェア支援がないのでしょう。IX2105の結果よりも悪いとは・・・。実運用環境じゃNATは使い物になりませんね。

C841MのConfig

NATはPATの設定のみ入れて、フィルタの設定はしていません。

ip dhcp pool dhcp-lan1
 network 192.168.100.0 255.255.255.0
 default-router 192.168.100.1 
 dns-server 192.168.100.1 
!
ip cef
no ipv6 cef
!
interface GigabitEthernet0/4
 ip address dhcp
 ip nat outside
!
interface Vlan1
 ip address 192.168.100.1 255.255.255.0
 ip nat inside
!
ip dns server
ip nat inside source list 1 interface GigabitEthernet0/4 overload
!
access-list 1 permit 192.168.100.0 0.0.0.255

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です