Cisco 841Mのルーティング スループット

ヤフオクとかで新品でも1万円以下で購入可能なCiscoルーターC841M-4X-JSEC/K9ですが、他のCiscoのルーターと違って保守契約なしにIOSのバージョンアップが出来、またコンソールポートもついているのでCiscoのコマンド学習等に最適です。

PPPoEやNATの処理が重く使えないという噂のあるC841Mですが、実際にスループットがどれくらい出るのか気になったので計測してみました。

計測環境

スイッチポート0(gigabitEthernet0/0)にCentOS7 Aをクライアント、gigabitEthernet0/4配下にCentOS7 Bをサーバーとして配置し、iperf3を実行しスループットの測定を行います。C841Mのファームウェアは15.5(3)M9となります。

計測結果

CentOS7 Aでのiperf3の実行結果が以下となります。-Mオプションを使ってMSSを変えてテストを行っています。TAP-TST10での目測値で、無負荷時の消費電力は6.3Wとなります(2ポートしか接続していない割には結構高い)。後で掲載のconfigにあるようにフィルタ等は一切設定しておりません。

sender
MSS Mbps CPU 消費電力
1460(指定なし) 937 28% 6.8W
1200 915 31% 6.9W
800 881 44% 6.9W
400 799 73% 6.9W

RTX1210のケースIX2105のケースと異なりCPU負荷はそこそこ低く抑えられています。ip cefの設定を入れていますがこれが効いているのでしょうか?フィルタなしという条件ですが、単純ルーティングであればC841Mは性能的に問題ないです。

C841MのConfig

以下のように非常にシンプルなconfigで検証しています。フィルタやNATの設定はありません。

ip dhcp pool dhcp-lan1
 network 192.168.100.0 255.255.255.0
 default-router 192.168.100.1
!
ip dhcp pool dhcp-lan2
 network 192.168.200.0 255.255.255.0
 default-router 192.168.200.1
!
ip cef
no ipv6 cef
!
interface GigabitEthernet0/4
 ip address 192.168.200.1 255.255.255.0
!
interface Vlan1
 ip address 192.168.100.1 255.255.255.0

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です